News: "We really love Bully ourselves and may also make a sequel at some point."


Author Topic: bypass pixel shader 3.0 requirement ( any command line arguments? )  (Read 9282 times)

0 Members and 1 Guest are viewing this topic.

Offline kutchbhi

  • Newbie
  • *
  • Posts: 5
    • View Profile
Hi
I get thes error when attempting to start bully (windows xp)
"bully requires a 32 bit display, and vertex and pixel shader model 3.0 support*

Now I understand , the only solution is to buy better a graphics card .
But is there a way to bypass this pixel shader  requirements? probably using some command line arguments or something? I know the game may give some errors..but I really wanna play this game..

Help!

Offline Bully_Nut

  • iMarcus
  • Bullworth Junkie
  • ****
  • Posts: 4,862
  • Country: au
  • Gender: Male
  • Trust Comes Tough.
    • View Profile
bypass pixel shader 3.0 requirement ( any command line arguments? )
« Reply #1 on: December 07, 2008, 04:04:39 am »
This is why I prefer console gaming. None of this better graphic card shit or error problems.

Just put the disc in and play.


Sorry mate, got no idea about bypassing.

Offline kutchbhi

  • Newbie
  • *
  • Posts: 5
    • View Profile
bypass pixel shader 3.0 requirement ( any command line arguments? )
« Reply #2 on: December 07, 2008, 04:37:04 am »
I found this 3d-analyze which is supposed to emulate shader 3 or just fool the game into thinking that shader 3 is present.

But this isn't  working , or I haven't managed to figure out how to  use this app. getting the same  error. :(

Offline kutchbhi

  • Newbie
  • *
  • Posts: 5
    • View Profile
bypass pixel shader 3.0 requirement ( any command line arguments? )
« Reply #3 on: December 09, 2008, 09:38:42 am »
the rabbit hole goes deeper than I had imagined..
Turns out it is a common problem with lazy ports - bioshock among others also required shader 3.0 support. Probably because xbox has a shader 3.0  chip and the devs did not bother adding shader 2.0 support to the pc version of their games.
However COD4, a console port, OFFICIALLY WORKED with shader 2.0. Here the devs did  bother to make the game as compatible as possible with the PC platform..(unlike in bully's case) by adding shader 2.0 support.

In bioshock's case there is a community made patch , enabling the game to run beautifully with shader 2.0 itself.
 Which is great news.. since it creates the possiblity of a shader 2.0 patch for bully.

EDIT: attempted to FIX HORRIBLE ENGLISH :oops:

btw crysis had shader 2.0 support..
« Last Edit: December 09, 2008, 03:05:02 pm by kutchbhi »

Offline DGAF

  • Admin
  • Administrator
  • Hero Member
  • *****
  • Posts: 1,892
    • View Profile
    • http://www.Bully-Board.com
bypass pixel shader 3.0 requirement ( any command line arguments? )
« Reply #4 on: December 09, 2008, 09:40:31 am »
Hmmm ^

(you're post)






(my head)

Chrissy

  • Guest
bypass pixel shader 3.0 requirement ( any command line arguments? )
« Reply #5 on: December 09, 2008, 08:08:42 pm »
Quote from: kutchbhi;67064
the rabbit hole goes deeper than I had imagined..
Turns out it is a common problem with lazy ports - bioshock among others also required shader 3.0 support. Probably because xbox has a shader 3.0  chip and the devs did not bother adding shader 2.0 support to the pc version of their games.
However COD4, a console port, OFFICIALLY WORKED with shader 2.0. Here the devs did  bother to make the game as compatible as possible with the PC platform..(unlike in bully's case) by adding shader 2.0 support.

In bioshock's case there is a community made patch , enabling the game to run beautifully with shader 2.0 itself.
 Which is great news.. since it creates the possiblity of a shader 2.0 patch for bully.

EDIT: attempted to FIX HORRIBLE ENGLISH :oops:

btw crysis had shader 2.0 support..

That's why I couldn't play Bioshock on my computer.

I've also heard that being lazy in that regard helps net higher sales of brand new graphic cards. It's win for them, fail for us.

Offline Bully_Nut

  • iMarcus
  • Bullworth Junkie
  • ****
  • Posts: 4,862
  • Country: au
  • Gender: Male
  • Trust Comes Tough.
    • View Profile
bypass pixel shader 3.0 requirement ( any command line arguments? )
« Reply #6 on: December 10, 2008, 03:55:49 am »
Congrats on work undertaken on finding the reason.

Your english is so much better then most of the retard 12 year old who have been taught english their whole life, so don't worry about that man.

 



anything
SimplePortal 2.3.3 © 2008-2010, SimplePortal